Quantcast

OpenESB 2.4 release and support for JBoss

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

OpenESB 2.4 release and support for JBoss

ville
This post has NOT been accepted by the mailing list yet.
Hi Forum!

We are currently starting a project where ESB product would save a lot of time and effort. I have already tried different ESB products (Mule, WSO2, TalendESB..) and OpenESB is our best option at this point.

Couple of questions:

1) Does version 2.4 already have some planned release date?
2) What JBoss versions does it support?

We are using JBoss EAP 6.2.4  (built from AS 7.3) and facing problems when trying to install Service Engines / Binding Components with help of these instructions: https://openesb.atlassian.net/wiki/display/ESBCOMP/Common+Installation+Steps

For example bpelse.jar throws:

08:25:03,548 WARNING [com.sun.jbi.framework] (Timer-1) JBIFW1107: Installation of Engine sun-bpel-engine failed. The bootstrap init() method threw a java.lang.ExceptionInInitializerError exception.
08:25:03,550 WARNING [com.sun.jbi.framework] (Timer-1) java.lang.ExceptionInInitializerError
        at com.sun.jbi.common.qos.config.ComponentConfig.parse(ComponentConfig.java:283)
        at com.sun.jbi.common.qos.config.ComponentConfig.parse(ComponentConfig.java:254)
....
Caused by: java.lang.NullPointerException
        at javax.xml.xpath.XPathFactoryFinder._newFactory(XPathFactoryFinder.java:220)
        at javax.xml.xpath.XPathFactoryFinder.newFactory(XPathFactoryFinder.java:141)
...

Thanks in advance and your work with the OpenESB!
-ville
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenESB 2.4 release and support for JBoss

David BRASSELY
Administrator
This post has NOT been accepted by the mailing list yet.
Hello ville,

Do you want to use only OpenESB for JBoss ?

Fell free to contact me: brasseld (at) gmail.com

Regards,
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenESB 2.4 release and support for JBoss

David BRASSELY
Administrator
This post has NOT been accepted by the mailing list yet.
Loading...