Composite Application says no valid application server is installed when I deploy

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Composite Application says no valid application server is installed when I deploy

stevetronix
This post has NOT been accepted by the mailing list yet.
This post was updated on .
I'm trying to deploy a composite application for a BPEL Module project in OpenESB 2.3.1, and when I deploy, it tells me "no valid application server is installed". However, I have GlassFish Server installed and running fine. GlassFish works fine with all other Web Service projects I've tried (SOAP, REST). I don't see a JBI node under "Servers". Should I have one? Thanks.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Composite Application says no valid application server is installed when I deploy

David BRASSELY
Administrator
This post has NOT been accepted by the mailing list yet.
Hi steve,

Again, please provide your IDE logs.

Cheers,
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Composite Application says no valid application server is installed when I deploy

stevetronix
This post has NOT been accepted by the mailing list yet.
It seems to work with GlassFish v2.x but not with GlassFish Server 4. However, I need GlassFish Server 4 because it is a Java EE 7 Web Compatible Server. It appears that v2.x is not EE 7 compatible. Is this correct?

I think BPEL doesn't seem to work with GlassFish Server 4 because a bpel module is missing.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Composite Application says no valid application server is installed when I deploy

smoczyna
This post has NOT been accepted by the mailing list yet.
In reply to this post by stevetronix
I don't use Mac but had the same issue on Linux some time ago. This is an installation issue, you need to remove your server and install it again.
Loading...